GOIM

Community

Copyright © 2007-2009 by Herbert Poul
You are not logged in.
Login
Register

Change Language:



AddThis Social Bookmark Button

A Django site.

Powered by Sphene Community Tools

Setup your Development Environment for GOIM2

Development / SetUpIDE

This guide will give a brief explaination on how to set up a development environment (using eclipse IDE) for GOIM 2. This is also required to compile GOIM 2 yourself.

1. Eclipse

First you need to download and install Eclipse for RCP/Plug-in Developers as well as at least JDK 5.0.

2. Subversive

To download the sources from subversion you will need to download subversive - the best would be through the eclipse update site: Help -> Software Updates -> Find and Install ...'Search for new Features to install' and add the update site (e.g. http://download.eclipse.org/technology/subversive/0.7/update-site/ )

3. Checkout

Open the subversion perspective: Window -> Open Perspective -> Other ... and choose 'SVN Repository Exploring'.

Add the GOIM 2 repository: File -> New -> Repository Location and enter the repository data. For the GOIM 2's public repository use:

URL: http://yourhell.com/svn/goim/branches/GOIMMultiProtocol/

and click 'Finish'.

Now in the 'SVN Repositories' view open the repository, open 'trunk' and select all required projects, right click and select 'Check Out'. You can see on the Development snip which projects you might need.

4. Launching GOIM 2

Switch back to the java perspective (Window -> Open Perspective -> Java) and open the project 'net.sphene.goim' - in it you should find a file called 'goim.product'. If you double click on it the Eclipse Product Editor should open and give you a link called 'Launch an Eclipse application'.

Last Modified: 2008-02-21 08:27:32 by Herbert Poul - [ Snip Changes ] [ Wiki History ]



Powered by Sphene Community Tools